Resolved: Elevated Errors Affecting Code Analysis and Code Viewing

Incident Report for SonarQube

Postmortem

Root Cause Analysis (RCA) External Document

Incident: SonarQube Cloud EU Outage on July 21, 2026

Incident Summary

On July 21, 2026, from 15:36 to 16:38 UTC, SonarQube Cloud EU experienced elevated errors that affected code analysis and code viewing. Customers may have encountered failed analyses, including HTTP 500 and 504 responses, during the affected period.

Incident Timeline (UTC)

  • 15:36: Errors began.
  • 15:39: Multiple high severity alarms were triggered and engineers started investigating the problem
  • 16:37: Engineering restored the affected API Lambda and reverted the deployment.
  • 16:38: Error rates returned to normal.
  • After mitigation: A resolved notice was posted on the status page.

Root Cause Analysis

A code change caused failures in a core Lambda function backing the API that retrieves source files from the database. This API is a critical step during the analysis process, thus all analyses began to fail.

Resolution

Engineering reverted the change to return to a known healthy state. Service error rates quickly returned to normal.

Preventive and Improvement Measures

  • Assess options to make analysis more resilient when dependent file-information requests are unavailable.
  • Improve our status-page process to ensure updates more closely align with observed service errors as they occur. - Completed

    • We recognize that the status page should have reflected this disruption sooner; going forward, we will publish an initial notice when a significant customer impact is identified, then provide follow-up updates as investigation and recovery progress.

We apologize for the disruption this incident caused and appreciate your patience.

Posted Jul 22, 2026 - 22:52 CEST

Resolved

Resolved: Between approximately 15:36 and 16:38 UTC, some customers experienced elevated errors affecting code analysis and code viewing. The issue has been resolved, and services are operating normally. We will continue to monitor the platform to ensure stability.
Posted Jul 21, 2026 - 19:03 CEST
This incident affected: SonarQube Cloud EU (Automatic Analysis) and SonarQube Cloud US (Automatic Analysis).