SonarQube Cloud: JaCoCo coverage is reporting as zero

Incident Report for SonarQube

Resolved

This incident has been resolved.
Posted Feb 02, 2026 - 20:00 CET

Identified

We are experiencing an issue resulting in JaCoCo coverage being reporting as zero. This could result in Quality Gates failing in error. The issue has been identified and is being addressed. After the issue is fixed, new analysis will be required to correct the Quality Gates.

Additional updates will be shared on this page as necessary. We apologize for any inconvenience.

To report additional issues or share your observations, please visit the Sonar Community or contact Support.
Posted Feb 02, 2026 - 17:37 CET
This incident affected: SonarQube Cloud EU (CI-based Analysis, Pull Request Experience) and SonarQube Cloud US (CI-based Analysis, Pull Request Experience).