SonarQube Cloud: US Region- Intermittent Failures on Endpoints

Incident Report for SonarQube

Resolved

We are happy to share the final significant update from AWS: the underlying DNS issue has been fully mitigated, and most AWS service operations are succeeding normally now.

This confirms that the root cause impacting our entitlement endpoints and the Bitbucket login on sonarcloud.io has been addressed.
If you are a user still experiencing issues resolving the DynamoDB service endpoints in US-EAST-1, AWS recommends flushing your DNS caches.

Thank you for your patience throughout this event. You can monitor the official AWS Health Dashboard here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 12:41 CEST

Update

We are pleased to share that Amazon Web Services (AWS) is observing continued recovery across most of the affected services in the US-EAST-1 Region.

AWS has also confirmed that global services and features that rely on US-EAST-1 have now recovered. This strongly suggests that the impact on our endpoints and the Bitbucket login on sonarcloud.io has subsided.

While AWS continues to work toward full resolution of the underlying issue, the major impact appears to be over. We will issue a final all-clear notification once we confirm sustained stability across all our services and the incident is officially closed by AWS.

You can monitor the official AWS Health Dashboard here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 12:25 CEST

Monitoring

We have received confirmation that Amazon Web Services (AWS) is now observing significant signs of recovery following the applied mitigations.
Most requests should now be succeeding, indicating that the core DNS resolution issue in US-EAST-1 is largely resolved.
Consequently, issues with our entitlement endpoints and Bitbucket login on sonarcloud.io should be improving rapidly.

AWS is working through a backlog of queued requests, so please note that you may still see slightly increased latency as the remaining work is fully processed.

We are continuing to monitor our services closely and will issue a final status notification once the incident is officially resolved.
You can follow the official AWS Health Dashboard for their next update: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 11:48 CEST

Update

We have received notification that Amazon Web Services (AWS) has implemented initial mitigation strategies for the DNS resolution issue in the US-EAST-1 Region.

We are actively monitoring our endpoints and the Bitbucket/sonarcloud.io login functionality to confirm full service restoration.

You can continue to track the official AWS Health Dashboard here: https://health.aws.amazon.com/health/status

We will provide our next update as soon as we have confirmation of full stability or further information from AWS.
Posted Oct 20, 2025 - 11:30 CEST

Identified

AWS has identified a potential root cause for the high error rates: a problem with DNS resolution for the DynamoDB API endpoint in the US-EAST-1 Region.

The issues affecting Bitbucket login on sonarcloud.io are consistent with this wider outage.

AWS is working on multiple parallel paths to accelerate recovery. Our team remains focused on monitoring their progress and preparing our systems for recovery once the AWS issue is resolved.

For the most immediate and detailed information, please monitor the official AWS Health Dashboard: https://health.aws.amazon.com/health/status

We will provide our next update as soon as AWS shares new information, or if we observe a change in service stability.
Posted Oct 20, 2025 - 11:07 CEST

Update

We are still experiencing intermittent failures on our endpoints and have observed that the underlying AWS issue is causing wider impact, specifically affecting Bitbucket login functionality on sonarcloud.io.

AWS is actively investigating the root cause of this infrastructure issue. Our teams are currently focused on closely monitoring their progress via their official status page and assessing the complete impact on our services.

For the latest updates from our infrastructure provider, please refer to the AWS Health Dashboard: https://health.aws.amazon.com/health/status

We will provide our next update immediately upon a significant status change from AWS.
Posted Oct 20, 2025 - 10:44 CEST

Investigating

We are currently experiencing an issue that may cause requests to our endpoints to fail intermittently.

This degradation is a result of an ongoing infrastructure issue being reported by Amazon Web Services (AWS). We are monitoring the situation closely and are awaiting updates from our provider.

You can track the status of the underlying infrastructure directly on the AWS Health Dashboard: https://health.aws.amazon.com/health/status

We apologize for the inconvenience and will provide our next update as soon as we receive new information from AWS.
Posted Oct 20, 2025 - 09:30 CEST
This incident affected: SonarQube Cloud EU (Third-Party Outages) and SonarQube Cloud US (Third-Party Outages).